1. Gwynfryn Thomas Gwynfryn Thomas France says:

    The download requires Win8, and claims to work with "any 3-D glasses" (I suppose I should have guessed!) of which I have neither, but never mind; something to look forward to...

The opinions expressed here are the views of the writer and do not necessarily reflect the views and opinions of News Medical.